#validns v0.10.0 released!
Added:
- Validate zones signed with Ed25519 and Ed448 (RFC 8080)
- Validate SVCB (TYPE 64) and HTTPS (TYPE 65) records per RFC 9460, including all nine IANA-registered SvcParam keys.
- CAA tag-value validation and RFC 8657 contact tags.
- Support the optional $INCLUDE argument: overrides $ORIGIN for the included file only.
plus many fixes, see changelog for full details!
#DNS #Zone #Validation #OpenSource
https://codeberg.org/DNS-OARC/validns/releases/tag/v0.10.0
Jerry Lundström
Software Engineer @DNS-OARC mainly tooting about releases, see @jelu@mastodon.social for more personal toots
#dnsperf v2.15.1 released!
- Fixed receiving DNS-over-HTTPS responses, incorrect handling in callbacks
- Update known QTYPE table
- Updates to CI
#DNS #Performance #Testing #OpenSource
https://codeberg.org/DNS-OARC/dnsperf/releases/tag/v2.15.1
#dnscap v2.5.2 released!
- Fix compatibility with GNU/Hurd
- Fix running tests in parallel
#DNS #Capture #OpenSource
https://codeberg.org/DNS-OARC/dnscap/releases/tag/v2.5.2
#dnsperf v2.15.0 released!
New features:
- statistics on unexpected DNS message IDs
- datafiles now support RFC1035 `\DDD` encoding
- Thanks to @iscdotorg@fosstodon.org, `dnsperf` statistics as JSON now available!
plus a few bug fixes, see release notes for full details.
^JL
#DNS #Performance #Testing #OpenSource
https://codeberg.org/DNS-OARC/dnsperf/releases/tag/v2.15.0
#dnswire v0.5.0 released!
- Updated DNSTAP, new HTTP Protocol Message attribute
- Fixed pkg-config dependencies
- Fixed missing decode checks
- Fixed enum unknown
- Fixed examples, packages and CI
#DNS #Encapsulation #Library #DNSTAP #OpenSource
https://codeberg.org/DNS-OARC/dnswire/releases/tag/v0.5.0
#validns v0.9.0 released!
- Support for WALLET and ZoneMD RR types
- Root zone membership check now correctly allows TLDs
- Report when DNSSEC signature algorithms are disabled by policy
- Several segfaults and code analysis issues fixed
and more, see full changelog for details!
#DNS #DNSSEC #Zone #Validation #OpenSource
https://codeberg.org/DNS-OARC/validns/releases/tag/v0.9.0
#dnsjit v1.5.1 released!
Fixes to DNS label handling:
- Use RFC 3597 format for unknown CLASS/TYPE
- Return root label instead of empty string
- `Label.torfc1035()` non-printable as per RFC 1035 sec. 5.1
#DNS #Toolkit #Scripting #Lua #LuaJIT #OpenSource
https://codeberg.org/DNS-OARC/dnsjit/releases/tag/v1.5.1
#dnscap v2.5.1 released!
- Fix `assert()` compatibility with newer libc
- In cryptopan plugin, support big endian systems
#DNS #Capture #OpenSource
https://codeberg.org/DNS-OARC/dnscap/releases/tag/v2.5.1
#dnscap v2.5.0 released!
- Two new plugin extensions
- Rewrote compressed PCAP reader to fix a lot of bugs
- Removed a very old PCAP header check to not discard valid packets
- Fix issues with `-e` filter option
See changelog for full details ^JL
#DNS #Capture #OpenSource
https://codeberg.org/DNS-OARC/dnscap/releases/tag/v2.5.0
#dnscap v2.4.0 released!
- Now supports reading gz/xz/lz4/zst compressed PCAPs
- Two new plugin extensions
- Autotool update and fixes
^JL
#DNS #Capture #OpenSource
https://github.com/DNS-OARC/dnscap/releases/tag/v2.4.0
#dnscap v2.4.1 released!
- fixed a bug introduced in v2.4.0 where writing gziped PCAPs broke
- readded sending timestamp to plugins close function which was incorrectly removed in v2.2.1
^JL
#DNS #Capture #OpenSource
https://github.com/DNS-OARC/dnscap/releases/tag/v2.4.1