Elektrine
Log in Register
Paige Chat Timeline Gallery Friends Email Drive DNS Private DNS Domains VPN Kairo Nerve
Remote

MoogleMaestro

@MoogleMaestro@lemmy.zip
lemmy 0.19.20
  • Open on lemmy.zip
0 Followers
0 Following
6 Posts
Joined July 26, 2024
Open post
MoogleMaestro @MoogleMaestro@lemmy.zip
· 1mo ago
Podman: Issues with multiple users running containers simultaneously Self cross-posting from: lemmy.zip/post/70909658 Intention to have slightly better visibility from the self-hosted crowd and I’m interested in more general feedback on this too. Hey everyone! I’m trying to find a solution to a really confusing problem… I have the following simple nginx docker compose configuration on my Fedora home server that I can run without issue on my uid 1000 user, lets call this user “userA”. services: nginx: container_name: nginx-alt image: docker.io/library/nginx restart: unless-stopped ports: - 8181:80 This exposes internal port 80 as 8181 and can be accessed in a lan in the expected matter. However, for security reasons, I want to actually host this service eventually on a completely different user with less permissions. Let’s call this user “userB” who has a very limited scope of the file system. This is to prevent potential escaping of the rootless container causing major file system havoc (i.e. reduce the scope of the user to a very limited network of containers.) The problem is really simple: For some reason, when userB runs this service (uid 1001), the nginx service suddenly complains about privileges. As a result, I get a “Forbidden 403” error when hosting. Turning off selinux has no affect (so setenforce 0 does nothing, meaning I can rule out secure linux interruption.) The errors look like the following: nginx-alt | 2026/09/04 20:03:34 [error] 25#25: *1 "/usr/share/nginx/html/index.html" is forbidden (13: Permission denied), client: xx.xx.x.x, server: localhost, request: "GET / HTTP/1.1", host: "xxx.xxx.xxx.xxx:8181" nginx-alt | 10.89.0.2 - - [04/Sep/2026:20:03:34 +0000] "GET / HTTP/1.1" 403 153 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:155.0) Gecko/20100101 Firefox/155.0" "-" For what it’s worth, both users should be relatively vanilla and all ports are appropriately exported. There shouldn’t be anything, for example, that is making userA run as “privileged” over the other users and podman should be running rootless in both containers. I did see a note on the nginx image about running in rootless that I might try, but it doesn’t solve my bigger issue here which is the lack of consistency between the two users. Additionally, userns_mode: keep-ids only caused the container to fail to boot for other reason entirely. There must be something fundamentally wrong with my configuration of my system. Has anyone had any experience running two podman containers on two different users simultaneously that can provide feedback? Obviously, I’m not trying to run just an nginx server, but I found this to be the easiest configuration to reproduce.
37
29
0
0
Open post
MoogleMaestro @MoogleMaestro@lemmy.zip
· 5mo ago
Now AI will participate in workplace theater for you!
43
0
0
0
Open post
MoogleMaestro @MoogleMaestro@lemmy.zip
· 5mo ago
Replying to
Microsoft needs to try to ruin Linux somehow, it can't just hurt windows 11 with AI slop code, it needs to expand it's efforts to other systems.
24
0
0
0
Open post
MoogleMaestro @MoogleMaestro@lemmy.zip
· 5mo ago
Replying to
It's definitely financially motivated. Linus said himself that AI has been very lucrative for Linux as it has expanded investment from companies that normally wouldn't give a fuck (he name dropped NVidia specifically) on that one LTT video.
10
0
0
0
Open post
MoogleMaestro @MoogleMaestro@lemmy.zip
· 5mo ago
I wonder what this will mean for Apple and whether this is an ominous foreshadowing of the ongoing hardware crisis. It seems to me like this would only be happening if the Macbook Neo has a difficult coming year or two down the line and he’s taking the fall preemptively. Either that or perhaps undisclosed health issues.
0
1
0
0
Open post
MoogleMaestro @MoogleMaestro@lemmy.zip
· 1mo ago
Replying to
No volumes mounted and yes, it’s using the podman backend. Just double checked it wasn’t using the docker one.
0
1
0
0
Back
313k7r1n3
Elektrine

Tor hidden service

elekhj7afj4qnrr4yd3bkzslsyo5jgfxw3orgjkhlcxifueodybyiiad.onion

I2P eepsite

j6b6cyk6gjmepjih7jjadxgxvvf3lzzujljuu2v4biemzpg3naya.b32.i2p

Platform

  • Email
  • Chat
  • Timeline
  • VPN
  • DNS

Company

  • About
  • Contact
  • FAQ
  • Lite (no JS)

Legal

  • Terms of Service
  • Privacy Policy
  • Transparency Report
  • Report Abuse
  • Warrant Canary
  • VPN Policy

Support

  • support@elektrine.com
  • Report Security Issue
Mail client setup IMAP mail.elektrine.com:993 POP3 mail.elektrine.com:995 SMTP mail.elektrine.com:465
© 2026 Elektrine. All rights reserved. Server: 21:40:48 UTC